Tickets - Login

Supported Browsers

Bolt recommends keeping your browsers up to date. This ensures that your coworkers have the best experience possible across all of your business tools.

Supported Browsers

  • Chrome 64+
  • Safari 12+
  • Firefox 67+
  • Edge 17+
  • Internet Explorer 11+ 1
  • iOS Safari 11.3+

  1. Microsoft is sunsetting Internet Explorer on August 17, 2021. This browser version does not support the latest web standards for browsers and is not recommended. ↩︎